$re = '/(?!(([^""]*""){2})*[^""]*$)\n+/';
$str = 'cztery;"pięć
";sześć
uno;"due;due";"tres
"';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;