const regex = new RegExp('(?!(([^""]*""){2})*[^""]*$)\\n+', 'g')
const str = `cztery;"pięć
";sześć
uno;"due;due";"tres
"`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);