use strict;
my $str = 'cztery;"pięć
";sześć
uno;"due;due";"tres
"';
my $regex = qr/(?!(([^""]*""){2})*[^""]*$)\n+/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";