package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href="(.*?)"> Read more\.\.\.<\/a>`)
var str = `"Overview bla bla . It is<a href="http://test.com/portfolio/wadf/"> Read more...</a>"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}