re = /<a href="(.*?)"> Read more\.\.\.<\/a>/
str = '"Overview bla bla . It is<a href="http://test.com/portfolio/wadf/"> Read more...</a>"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end