import Foundation
let pattern = #"<a href="(.*?)"> Read more\.\.\.<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""Overview bla bla . It is<a href="http://test.com/portfolio/wadf/"> Read more...</a>""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}