#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:\bp(?:\.|ost)?\s*o(?:\.|ffice)?\s*)?box\s*(\d+)\b"
Local $sString = "sssss post office Box 12 Floor 105 Tallapoosa Street" & @CRLF & _
"sss leclair ryan pc p.o. Box 2499 8th floor 951 east byrd street" & @CRLF & _
"ss box 1 slot 3 building 2 136 harvey road";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")