// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:\bp(?:\.|ost)?\s*o(?:\.|ffice)?\s*)?box\s*(\d+)\b").unwrap();
let string = "sssss post office Box 12 Floor 105 Tallapoosa Street
sss leclair ryan pc p.o. Box 2499 8th floor 951 east byrd street
ss box 1 slot 3 building 2 136 harvey road\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}