import Foundation
let pattern = #"(?i)(?:\bp(?:\.|ost)?\s*o(?:\.|ffice)?\s*)?box\s*(\d+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
sssss post office Box 12 Floor 105 Tallapoosa Street
sss leclair ryan pc p.o. Box 2499 8th floor 951 east byrd street
ss box 1 slot 3 building 2 136 harvey road";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)