$re = '/(?i)(?:\bp(?:\.|ost)?\s*o(?:\.|ffice)?\s*)?box\s*(\d+)\b/';
$str = 'sssss post office Box 12 Floor 105 Tallapoosa Street
sss leclair ryan pc p.o. Box 2499 8th floor 951 east byrd street
ss box 1 slot 3 building 2 136 harvey road";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);