use strict;
my $str = 'sssss post office Box 12 Floor 105 Tallapoosa Street
sss leclair ryan pc p.o. Box 2499 8th floor 951 east byrd street
ss box 1 slot 3 building 2 136 harvey road";';
my $regex = qr/(?i)(?:\bp(?:\.|ost)?\s*o(?:\.|ffice)?\s*)?box\s*(\d+)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}