# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?:\bp(?:\.|ost)?\s*o(?:\.|ffice)?\s*)?box\s*(\d+)\b"
test_str = ("sssss post office Box 12 Floor 105 Tallapoosa Street\n"
"sss leclair ryan pc p.o. Box 2499 8th floor 951 east byrd street\n"
"ss box 1 slot 3 building 2 136 harvey road\";")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.