#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[Section 1\][^[]*name\s*=\s*(.*)"
Local $sString = "[Section 1]" & @CRLF & _
" title = RegEx" & @CRLF & _
" name = Joe" & @CRLF & _
" color = blue" & @CRLF & _
"[Section 2]" & @CRLF & _
" height = 101" & @CRLF & _
" name = Gray"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")