re = /\[Section 1\][^[]*name\s*=\s*(.*)/
str = '[Section 1]
title = RegEx
name = Joe
color = blue
[Section 2]
height = 101
name = Gray'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end