import Foundation
let pattern = #"\[Section 1\][^[]*name\s*=\s*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[Section 1]
title = RegEx
name = Joe
color = blue
[Section 2]
height = 101
name = Gray
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)