// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[Section 1\][^[]*name\s*=\s*(.*)").unwrap();
let string = "[Section 1]
title = RegEx
name = Joe
color = blue
[Section 2]
height = 101
name = Gray";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}