using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[Section 1\][^[]*name\s*=\s*(.*)";
string input = @"[Section 1]
title = RegEx
name = Joe
color = blue
[Section 2]
height = 101
name = Gray";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}