$re = '/\[Section 1\][^[]*name\s*=\s*(.*)/';
$str = '[Section 1]
title = RegEx
name = Joe
color = blue
[Section 2]
height = 101
name = Gray';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);