#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!(?:@|.@|.{2}@|.{3}@|.{4}@))(.*?@.*?)@.*$"
Local $sString = "abcd@varun@gmail.com" & @CRLF & _
"abcde@varun@gmail.com"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)