re = /^(?!(?:@|.@|.{2}@|.{3}@|.{4}@))(.*?@.*?)@.*$/m
str = 'abcd@varun@gmail.com
abcde@varun@gmail.com'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result