use strict;
my $str = 'abcd@varun@gmail.com
abcde@varun@gmail.com';
my $regex = qr/^(?!(?:@|.@|.{2}@|.{3}@|.{4}@))(.*?@.*?)@.*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";