import re
regex = re.compile(r"^(?!(?:@|.@|.{2}@|.{3}@|.{4}@))(.*?@.*?)@.*$", flags=re.MULTILINE)
test_str = ("abcd@varun@gmail.com\n"
"abcde@varun@gmail.com")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)