const regex = /^(?!(?:@|.@|.{2}@|.{3}@|.{4}@))(.*?@.*?)@.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:@|.@|.{2}@|.{3}@|.{4}@))(.*?@.*?)@.*$', 'gm')
const str = `abcd@varun@gmail.com
abcde@varun@gmail.com`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);