using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:@|.@|.{2}@|.{3}@|.{4}@))(.*?@.*?)@.*$";
string substitution = @"$1";
string input = @"abcd@varun@gmail.com
abcde@varun@gmail.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}