#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*?([A-D]).*?\1)[A-D](?:,[A-D])*$"
Local $sString = "A" & @CRLF & _
"C" & @CRLF & _
"C,B" & @CRLF & _
"B,D" & @CRLF & _
"D,B,A,C" & @CRLF & _
"A,A" & @CRLF & _
"ABC" & @CRLF & _
"D,B,A,B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")