using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?([A-D]).*?\1)[A-D](?:,[A-D])*$";
string input = @"A
C
C,B
B,D
D,B,A,C
A,A
ABC
D,B,A,B";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}