const regex = /^(?!.*?([A-D]).*?\1)[A-D](?:,[A-D])*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?([A-D]).*?\\1)[A-D](?:,[A-D])*$', 'gm')
const str = `A
C
C,B
B,D
D,B,A,C
A,A
ABC
D,B,A,B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}