$re = '/^(?!.*?([A-D]).*?\1)[A-D](?:,[A-D])*$/m';
$str = 'A
C
C,B
B,D
D,B,A,C
A,A
ABC
D,B,A,B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);