re = /^(?!.*?([A-D]).*?\1)[A-D](?:,[A-D])*$/m
str = 'A
C
C,B
B,D
D,B,A,C
A,A
ABC
D,B,A,B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end