import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*?([A-D]).*?\\1)[A-D](?:,[A-D])*$";
final String string = "A\n"
+ "C\n"
+ "C,B\n"
+ "B,D\n"
+ "D,B,A,C\n"
+ "A,A\n"
+ "ABC\n"
+ "D,B,A,B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}