#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\w+\()\w+?\(([\s'!\\\)",\w]+)+\);"
Local $sString = "_("hello"); // should grab "hello"" & @CRLF & _
"_('foo"!\'bar'); // should grab "foo"!\'bar"" & @CRLF & _
"_t("hello\"!)' you"); // should grab "hello\"!)' you"" & @CRLF & _
"_n("foo", "bar", 4); // should grab "foo" and "bar"" & @CRLF & _
"_n('foo', 'bar', 4);" & @CRLF & _
"" & @CRLF & _
"{{_ "hello" }}" & @CRLF & _
"{{_t "hello" }}" & @CRLF & _
"{{_n "hello {{ count }}" "{{ count }} bar" count="4" }}" & @CRLF & _
"" & @CRLF & _
"gettext("foo"); // should grab "foo"" & @CRLF & _
"ngettext("bar", "baz", 42); // should grab "bar" and "baz"" & @CRLF & _
"dgettext(domain, "bux"); // should grab "bux"" & @CRLF & _
"" & @CRLF & _
"_( "bar" );" & @CRLF & _
"_n( "baz", "bux", 42);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")