import re
regex = re.compile(r"^(?=\w+\()\w+?\(([\s'!\\\)\",\w]+)+\);", flags=re.MULTILINE)
test_str = ("_(\"hello\"); // should grab \"hello\"\n"
"_('foo\"!\\'bar'); // should grab \"foo\"!\\'bar\"\n"
"_t(\"hello\\\"!)' you\"); // should grab \"hello\\\"!)' you\"\n"
"_n(\"foo\", \"bar\", 4); // should grab \"foo\" and \"bar\"\n"
"_n('foo', 'bar', 4);\n\n"
"{{_ \"hello\" }}\n"
"{{_t \"hello\" }}\n"
"{{_n \"hello {{ count }}\" \"{{ count }} bar\" count=\"4\" }}\n\n"
"gettext(\"foo\"); // should grab \"foo\"\n"
"ngettext(\"bar\", \"baz\", 42); // should grab \"bar\" and \"baz\"\n"
"dgettext(domain, \"bux\"); // should grab \"bux\"\n\n"
"_( \"bar\" );\n"
"_n( \"baz\", \"bux\", 42);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")