import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\w+\\()\\w+?\\(([\\s'!\\\\\\)\",\\w]+)+\\);";
final String string = "_(\"hello\"); // should grab \"hello\"\n"
+ "_('foo\"!\\'bar'); // should grab \"foo\"!\\'bar\"\n"
+ "_t(\"hello\\\"!)' you\"); // should grab \"hello\\\"!)' you\"\n"
+ "_n(\"foo\", \"bar\", 4); // should grab \"foo\" and \"bar\"\n"
+ "_n('foo', 'bar', 4);\n\n"
+ "{{_ \"hello\" }}\n"
+ "{{_t \"hello\" }}\n"
+ "{{_n \"hello {{ count }}\" \"{{ count }} bar\" count=\"4\" }}\n\n"
+ "gettext(\"foo\"); // should grab \"foo\"\n"
+ "ngettext(\"bar\", \"baz\", 42); // should grab \"bar\" and \"baz\"\n"
+ "dgettext(domain, \"bux\"); // should grab \"bux\"\n\n"
+ "_( \"bar\" );\n"
+ "_n( \"baz\", \"bux\", 42);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}