re = /^(?=\w+\()\w+?\(([\s'!\\\)",\w]+)+\);/m
str = '_("hello"); // should grab "hello"
_(\'foo"!\\\'bar\'); // should grab "foo"!\\\'bar"
_t("hello\\"!)\' you"); // should grab "hello\\"!)\' you"
_n("foo", "bar", 4); // should grab "foo" and "bar"
_n(\'foo\', \'bar\', 4);
{{_ "hello" }}
{{_t "hello" }}
{{_n "hello {{ count }}" "{{ count }} bar" count="4" }}
gettext("foo"); // should grab "foo"
ngettext("bar", "baz", 42); // should grab "bar" and "baz"
dgettext(domain, "bux"); // should grab "bux"
_( "bar" );
_n( "baz", "bux", 42);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end