package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/embed\.app\.com\/((?:packages)|(?:videos))\/([0-9]+)`)
var str = `http://embed.app.com/packages/495
https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}