re = /https?:\/\/embed\.app\.com\/((?:packages)|(?:videos))\/([0-9]+)/
str = 'http://embed.app.com/packages/495
https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end