// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?:\/\/embed\.app\.com\/((?:packages)|(?:videos))\/([0-9]+)").unwrap();
let string = "http://embed.app.com/packages/495
https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}