$re = '/https?:\/\/embed\.app\.com\/((?:packages)|(?:videos))\/([0-9]+)/';
$str = 'http://embed.app.com/packages/495
https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);