const regex = /https?:\/\/embed\.app\.com\/((?:packages)|(?:videos))\/([0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/embed\\.app\\.com\\\/((?:packages)|(?:videos))\\\/([0-9]+)', 'g')
const str = `http://embed.app.com/packages/495
https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}