import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/embed\\.app\\.com\\/((?:packages)|(?:videos))\\/([0-9]+)";
final String string = "http://embed.app.com/packages/495\n"
+ "https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}