using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\?{2}Company=)(.*?)(?=\?{2})";
string substitution = @"";
string input = @"??Company=My Company Name Ltd??Address= 29 Acacia Road, Nuttytown, AA1 9AA??Description=A very rampling description here... goes on for a bit and then somemore??E-mail=bert@bertswork.com??Version=Super Plus??Expiration date=01/01/2026??First name=Bert??Last name=Bloggs??";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}