const regex = /(?<=\?{2}Company=)(.*?)(?=\?{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\?{2}Company=)(.*?)(?=\\?{2})', 'g')
const str = `??Company=My Company Name Ltd??Address= 29 Acacia Road, Nuttytown, AA1 9AA??Description=A very rampling description here... goes on for a bit and then somemore??E-mail=bert@bertswork.com??Version=Super Plus??Expiration date=01/01/2026??First name=Bert??Last name=Bloggs??`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);