import re
regex = re.compile(r"(?<=\?{2}Company=)(.*?)(?=\?{2})")
test_str = "??Company=My Company Name Ltd??Address= 29 Acacia Road, Nuttytown, AA1 9AA??Description=A very rampling description here... goes on for a bit and then somemore??E-mail=bert@bertswork.com??Version=Super Plus??Expiration date=01/01/2026??First name=Bert??Last name=Bloggs??"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)