use strict;
my $str = '??Company=My Company Name Ltd??Address= 29 Acacia Road, Nuttytown, AA1 9AA??Description=A very rampling description here... goes on for a bit and then somemore??E-mail=bert@bertswork.com??Version=Super Plus??Expiration date=01/01/2026??First name=Bert??Last name=Bloggs??';
my $regex = qr/(?<=\?{2}Company=)(.*?)(?=\?{2})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";