#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)\[quote\]((?&core)|)\[\/quote\]$(?(DEFINE)(?<core>(?>(?&content)|\[quote\](?:(?&core)|)\[\/quote\])+)(?<content>(?>(?!\[\/?quote\]).)+))"
Local $sString = "Here is the example post text" & @CRLF & _
"" & @CRLF & _
"[QUOTE]" & @CRLF & _
"This is an appropriate quote" & @CRLF & _
"[/QUOTE]" & @CRLF & _
"" & @CRLF & _
"Here is more post content" & @CRLF & _
"" & @CRLF & _
"[QUOTE]" & @CRLF & _
"This is an unnecessary quote, as it's below all of the post text" & @CRLF & _
" [QUOTE]" & @CRLF & _
" Here's an unnecessary nested quote, just to confuse things." & @CRLF & _
" [/QUOTE]" & @CRLF & _
"[/QUOTE]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")