const regex = /(?is)\[quote\]((?&core)|)\[\/quote\]$(?(DEFINE)(?<core>(?>(?&content)|\[quote\](?:(?&core)|)\[\/quote\])+)(?<content>(?>(?!\[\/?quote\]).)+))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?is)\\[quote\\]((?&core)|)\\[\\\/quote\\]$(?(DEFINE)(?<core>(?>(?&content)|\\[quote\\](?:(?&core)|)\\[\\\/quote\\])+)(?<content>(?>(?!\\[\\\/?quote\\]).)+))', '')
const str = `Here is the example post text
[QUOTE]
This is an appropriate quote
[/QUOTE]
Here is more post content
[QUOTE]
This is an unnecessary quote, as it's below all of the post text
[QUOTE]
Here's an unnecessary nested quote, just to confuse things.
[/QUOTE]
[/QUOTE]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}