use strict;
my $str = 'Here is the example post text
[QUOTE]
This is an appropriate quote
[/QUOTE]
Here is more post content
[QUOTE]
This is an unnecessary quote, as it\'s below all of the post text
[QUOTE]
Here\'s an unnecessary nested quote, just to confuse things.
[/QUOTE]
[/QUOTE]';
my $regex = qr/(?is)\[quote\]((?&core)|)\[\/quote\]$(?(DEFINE)(?<core>(?>(?&content)|\[quote\](?:(?&core)|)\[\/quote\])+)(?<content>(?>(?!\[\/?quote\]).)+))/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}