# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?is)\[quote\]((?&core)|)\[\/quote\]$(?(DEFINE)(?<core>(?>(?&content)|\[quote\](?:(?&core)|)\[\/quote\])+)(?<content>(?>(?!\[\/?quote\]).)+))"
test_str = ("Here is the example post text\n\n"
"[QUOTE]\n"
"This is an appropriate quote\n"
"[/QUOTE]\n\n"
"Here is more post content\n\n"
"[QUOTE]\n"
"This is an unnecessary quote, as it's below all of the post text\n"
" [QUOTE]\n"
" Here's an unnecessary nested quote, just to confuse things.\n"
" [/QUOTE]\n"
"[/QUOTE]")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.