$re = '/(?is)\[quote\]((?&core)|)\[\/quote\]$(?(DEFINE)(?<core>(?>(?&content)|\[quote\](?:(?&core)|)\[\/quote\])+)(?<content>(?>(?!\[\/?quote\]).)+))/';
$str = 'Here is the example post text
[QUOTE]
This is an appropriate quote
[/QUOTE]
Here is more post content
[QUOTE]
This is an unnecessary quote, as it\'s below all of the post text
[QUOTE]
Here\'s an unnecessary nested quote, just to confuse things.
[/QUOTE]
[/QUOTE]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);