import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^/[A-Za-z\\d\\u00C0-\\u00D6\\u00D8-\\u00F6\\u00F8-\\u00FF\\u0100-\\u0148\\u014A-\\u024F\\u1E02-\\u1EF3\\u2C60-\\u2C7F\\uA720-\\uA7FF\\uAB30-\\uAB6F \\$\\,\\.\\(\\)\\?\\xBF\\xA1\\!\\%\\#\\@\\xA2]*";
final String string = "AB cµÀ´'(-+=0123¢-1-\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}